Subtitle issue with WDTV PLAY Media Player. SOLVED!

  • Hello,

    My favorite DivX playback units are finally biting the dust. I've had this WDTV Play unit sitting on the shelf for at least 3 or 4 years. I set it up three days ago, and began putting it through the discovery phase. Not bad, certain familiarizing sessions, one big uh-oh problem. It won't play .srt subtitles. If the Movie has hardcoded subs, no problem. If it's an .avi with the .srt in the same folder, nothing. If I ran the same through ConvertXtoDVD with the subs installed, nothing. That's the basic info on what I'm working with. I have spent the weekend going through WD support, and googling every possible solution. I've tried converting .srt from ANSI and saving as UTF-8. Still no love. WD says it doesn't support ANSI, so I'm definitely in need of help. I've great hopes someone in the Hive has gone through this, and can shed some light on the problem. Could it be firmware update? I haven't seen anything on WD that address an update as a solution. BTW, I'm impressed with it's abilit to playback everything I've put in. MP4, MKV, ISO, etc. Will save a lot of time converting to Xvid. Now if I can just get the damn thing to handle subs! I only have a handful of these problem files in the library, and they will all play through fine on the DivX units. But as I said, those are dying. They play just fine through the Computer. Thanks for any help.

    Please help

    I didn't find the right solution from the internet.

    Teaser video production agency

    Thank you